AirBuddy Help CenterContact Support

Which headsets are supported by AirBuddy?

AirBuddy supports all Apple and Beats headsets equipped with the W1 or H1 wireless chip. Click here to learn more about support for other types of accessories.

Device support depends on the operating system version. AirBuddy relies on the Bluetooth stack on macOS, so if a device with new features was released after the version of macOS that you're running, you might experience some limitations. Check out the information below for more details.

Device macOS 10.14.6 macOS 10.15 macOS 11.0
AirPods (1st gen.)
AirPods (2st gen.)
AirPods Pro* 🟥 ✅**
Beats Solo Pro* 🟥 ✅**
Powerbeats (all generations)
Powerbeats Pro
Beats Solo³
Beats Studio³
Beatsˣ
Beats Flex

* AirPods Pro and Beats Solo Pro require macOS 10.15.1 or later for full functionality. They will work on previous versions, but changing listening modes, showing the status window automatically and showing the status for the charging case might not work.

** Requires macOS 10.15.1 or later for full functionality