AirBuddy Help CenterSend Feedback

Which headsets are supported by AirBuddy?

AirBuddy supports all Apple and Beats headsets equipped with the W1 or H1 wireless chip. Click here to learn more about support for other types of accessories.

Device support depends on the operating system version. AirBuddy relies on the Bluetooth stack on macOS, so if a device with new features was released after the version of macOS that you're running, you may experience some limitations. Check out the information below for more details.

Device macOS 10.14.6 macOS 10.15 macOS 11.0 macOS 12.0 macOS 13.0
AirPods (1st gen.)
AirPods (2st gen.)
AirPods (3rd gen.) 🟥 ✅⁵ ✅⁵
Beats Fit Pro 🟥 ✅⁵ ✅⁵
AirPods Pro (¹) 🟥 ✅²
AirPods Pro (2nd gen.) 🟥 🟥 🟥 🟥⁷ ✅⁷
AirPods Max (¹) 🟥 🟥 ✅³
Beats Solo Pro (¹) 🟥 ✅²
Powerbeats (all generations)
Powerbeats Pro
Beats Solo³
Beats Studio³
Beatsˣ
Beats Flex
Beats Studio Buds (⁴) 🟥 🟥
Headsets from other manufacturers 🟥 🟥 🟥 ✅⁶ ✅⁶

¹ AirPods Pro and Beats Solo Pro require macOS 10.15.1 or later for full functionality. AirPods Max requires macOS 11.1 and AirBuddy 2.2 for full functionality. These will work on previous versions, but changing listening modes, showing the status window automatically and showing the status for the charging case may not work.

² Requires macOS 10.15.1 or later for full functionality

³ Requires macOS 11.1 or later and AirBuddy 2.2 or later for full functionality

⁴ Beats Studio Buds require macOS 11.4 or later and AirBuddy 2.4.2 or later. They don't have the W1 or H1 chip, so some features are not supported. Learn more about using your Beats Studio Buds with AirBuddy.

⁵ AirPods (3rd generation) require macOS Monterey (12.0.1) or later and AirBuddy 2.4.5 or later for full functionality. Beats Fit Pro requires AirBuddy 2.5 or later for full functionality.

⁶ Functionality is limited for devices that are not made by Apple or Beats. You can learn more here.

⁷ AirPods Pro (2nd generation) require macOS 13.0 or later and AirBuddy 2.6 or later for full functionality.